Page 1 of 1

GLES render issues..

PostPosted: Dec 2, 2009 @ 9:42am
by RapchikProgrammer
Hey, now i have 2 problems..

1) All opengles 1.1 calls like vbos and texparameteri bring up a 'feature not supported' error on nokia n82 and n95 devices even though they support opengles 1.1

2) Even trying to render using glDrawElements, i get to render everything perfectly under windows.. on device, it shows all 2d blt calls but nothing 3d.. any guess what could be going different between gl and gles??

PostPosted: Dec 2, 2009 @ 10:37am
by RapchikProgrammer
I finally fixed problem 2, turns out the default frustrum clips everything in the scene.. i sorted it out to my needs and now it works fine.. i still cant figure out how to fix problem 1..

PostPosted: Dec 5, 2009 @ 3:20pm
by edge

EDGELIB doesn't actually specify an OpenGL ES version for Symbian, so I'm not sure why these functions fail. Perhaps you can try to call eglInitialize(eglGetDisplay(EGL_DEFAULT_DISPLAY), vermajor, verminor) and see which OpenGL ES version it returns for your devices? Try to call it before EDGELIB does (for example, in OnDisplayConfig).

PostPosted: Dec 7, 2009 @ 8:30am
by kuroneko
FWIW, calling eglInitialize() only gives you the EGL version. To obtain the GL|ES version you have to put in more effort, i.e. create a GL|ES context, make it current, then issue glGetString(GL_VERSION) etc.

PostPosted: Dec 9, 2009 @ 9:04pm
by RapchikProgrammer

PostPosted: Dec 10, 2009 @ 1:31am
by kuroneko

PostPosted: Dec 10, 2009 @ 11:18am
by RapchikProgrammer

PostPosted: Dec 11, 2009 @ 10:50am
by RapchikProgrammer
Fixed it, i just noticed this part in the documentation that helped me fix it:

1. Go to the epoc32\release\armv5\lib\ -directory under the SDK installation (typically C:\Symbian\9.1\S60_3rd\Epoc32\release\armv5\lib\).

2. Copy the file libGLES_CM.dso over the file libgles_cm{000a0000}.dso.

3. Copy the file libGLES_CM.lib over the file libgles_cm{000a0000}.lib.